#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=.*\.)([^/]+$)"
Local $sString = "http://www.example.es/cat1/cat2/some-example_DH148439#.Rh1-js_4" & @CRLF & _
"http://www.example.es/cat1/cat2/cat3"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)