re = /(?=.*\.)([^\/]+$)/m
str = 'http://www.example.es/cat1/cat2/some-example_DH148439#.Rh1-js_4
http://www.example.es/cat1/cat2/cat3'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result