const regex = /(?=.*\.)([^/]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\.)([^\/]+$)', 'gm')
const str = `http://www.example.es/cat1/cat2/some-example_DH148439#.Rh1-js_4
http://www.example.es/cat1/cat2/cat3`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);