using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*([a-qA-Q])\1{5,})[a-qA-Q]{6,24}$";
string input = @"aabbbbbccc
aaAA
aaaaaaAA
aaAAAAAA
aaaaaaAAAAAA
aaaaaaAAAAAAAAAAAAAAAAAAA
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}