re = /^(?=.*([a-qA-Q])\1{5,})[a-qA-Q]{6,24}$/m
str = 'aabbbbbccc
aaAA
aaaaaaAA
aaAAAAAA
aaaaaaAAAAAA
aaaaaaAAAAAAAAAAAAAAAAAAA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end