$re = '/^(?=.*([a-qA-Q])\1{5,})[a-qA-Q]{6,24}$/m';
$str = 'aabbbbbccc
aaAA
aaaaaaAA
aaAAAAAA
aaaaaaAAAAAA
aaaaaaAAAAAAAAAAAAAAAAAAA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);