using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z](?=(?:.*?[a-z]){3})(?=.*?[A-Z]).*)$";
string input = @"Aasd23#$s
aAas23$%6$
Aasd23#$sA
aAas23$%6$a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}