$re = '/^([a-zA-Z](?=(?:.*?[a-z]){3})(?=.*?[A-Z]).*)$/m';
$str = 'Aasd23#$s
aAas23$%6$
Aasd23#$sA
aAas23$%6$a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);