re = /^([a-zA-Z](?=(?:.*?[a-z]){3})(?=.*?[A-Z]).*)$/m
str = 'Aasd23#$s
aAas23$%6$
Aasd23#$sA
aAas23$%6$a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end