import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[-\\w\\d?*.+|\\{\\}\\\\\\/\\s<>\\]\\(])|(?:\\\\[\\[\\]()])|^[\\[(].+?[\\])])+\\s*(?<valid>(?:#+).*)$|^[-\\[\\w\\d?*.+|\\{\\}\\\\\\/\\s<>\\(]+(?<invalid>(?:#+).*)$";
final String string = "(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)\n"
+ "([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)\n"
+ "(\\||\\[|\\?) # match some stuff (escaped opening square bracket)\n\n"
+ "[A-Za-z # letters\n"
+ "0-9_-.] ### stuff\n\n"
+ "(\\[ # works if escaped [ is in group\n\n"
+ "\\[ # and on its own...\n\n"
+ "if | pass | raise | return | try | while | with # this should be a comment\n\n"
+ "\\h # a hex digit";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}