# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[-\w\d?*.+|{}\\\/\s<>\]\(])|(?:\\[\[\]()])|^[\[(].+?[\])])+\s*(?<valid>(?:#+).*)$|^[-\[\w\d?*.+|{}\\\/\s<>\(]+(?<invalid>(?:#+).*)$"
test_str = ("(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)\n"
"([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)\n"
"(\\||\\[|\\?) # match some stuff (escaped opening square bracket)\n\n"
"[A-Za-z # letters\n"
"0-9_-.] ### stuff\n\n"
"(\\[ # works if escaped [ is in group\n\n"
"\\[ # and on its own...\n\n"
"if | pass | raise | return | try | while | with # this should be a comment\n\n"
"\\h # a hex digit")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.