const regex = /^(?:(?:[-\w\d?*.+|{}\\\/\s<>\]\(])|(?:\\[\[\]()])|^[\[(].+?[\])])+\s*(?<valid>(?:#+).*)$|^[-\[\w\d?*.+|{}\\\/\s<>\(]+(?<invalid>(?:#+).*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[-\\w\\d?*.+|{}\\\\\\\/\\s<>\\]\\(])|(?:\\\\[\\[\\]()])|^[\\[(].+?[\\])])+\\s*(?<valid>(?:#+).*)$|^[-\\[\\w\\d?*.+|{}\\\\\\\/\\s<>\\(]+(?<invalid>(?:#+).*)$', 'gm')
const str = `(\\h{8}-\\h{4}-\\h{4}-\\h{4}-\\h{12}) # match UUID (no square brackets at all)
([A-Za-z_][A-Za-z0-9_]*) # valid Python identifier (paired unescaped square brackets)
(\\||\\[|\\?) # match some stuff (escaped opening square bracket)
[A-Za-z # letters
0-9_-.] ### stuff
(\\[ # works if escaped [ is in group
\\[ # and on its own...
if | pass | raise | return | try | while | with # this should be a comment
\\h # a hex digit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}