import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[|,|^)[\\t ]*((?'type'[a-zA-Z0-9_.\\[\\]]+)(?:[\\t ]*\\|[\\t ]*(?&type))+)(?:\\]|,|$)";
final String string = "str|int|bool\n"
+ "int | tuple[str|int] | bool\n"
+ "Decimal|datetime.date|str\n"
+ "str|Optional[int]\n"
+ "Optional[int|str]\n"
+ "dict[str | int, list[B | C | Optional[D]]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}