re = /(?:\[|,|^)[\t ]*((?'type'[a-zA-Z0-9_.\[\]]+)(?:[\t ]*\|[\t ]*(?&type))+)(?:\]|,|$)/m
str = 'str|int|bool
int | tuple[str|int] | bool
Decimal|datetime.date|str
str|Optional[int]
Optional[int|str]
dict[str | int, list[B | C | Optional[D]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end