package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name=\'(?<name>[^\']+)\'`)
var str = `2019-05-17 11:30:14.262 INFO 13 --- [pool-3-thread-1] com.abcd.efgh.ijk.statuspage.StatusPage : Application[id=00, name='XYZ Service', environment='Production', status='DOWN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}