re = /name=\'(?<name>[^\']+)\'/m
str = '2019-05-17 11:30:14.262 INFO 13 --- [pool-3-thread-1] com.abcd.efgh.ijk.statuspage.StatusPage : Application[id=00, name=\'XYZ Service\', environment=\'Production\', status=\'DOWN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end