$re = '/name=\'(?<name>[^\']+)\'/m';
$str = '2019-05-17 11:30:14.262 INFO 13 --- [pool-3-thread-1] com.abcd.efgh.ijk.statuspage.StatusPage : Application[id=00, name=\'XYZ Service\', environment=\'Production\', status=\'DOWN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);