package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)\h*:\h*(.+)`)
var str = `FOO:317263
BAR:abcd
BAZ:s fsiu sfd sdf s dfsdddddd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}