$re = '/^(\w+)\h*:\h*(.+)/m';
$str = 'FOO:317263
BAR:abcd
BAZ:s fsiu sfd sdf s dfsdddddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);