re = /^(\w+)\h*:\h*(.+)/m
str = 'FOO:317263
BAR:abcd
BAZ:s fsiu sfd sdf s dfsdddddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end