using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\AX{2}-X{6}$\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z";
string input = @"XX-XXXXXX";
RegexOptions options = RegexOptions.ExplicitCapture;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}