import re
regex = re.compile(r"\AX{2}-X{6}$\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z")
test_str = "XX-XXXXXX"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")