#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?n)\AX{2}-X{6}\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z"
Local $sString = "XX-XXXXXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")