package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\AX{2}-X{6}\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z`)
var str = `XX-XXXXXX`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}