re = /\AX{2}-X{6}\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z/
str = 'XX-XXXXXX'
# Print the match result
str.match(re) do |match|
puts match.to_s
end