#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/.*(?<!foo\/bar\/(aaa|bbb|ccc|ddd))$"
Local $sString = "/toto/titi" & @CRLF & _
"/foo/toto" & @CRLF & _
"/foo/bar/aaa" & @CRLF & _
"/foo/bar/bbb" & @CRLF & _
"/bar/yeepa" & @CRLF & _
"/foo/bar/ccc" & @CRLF & _
"/foo/bar/ddd" & @CRLF & _
"/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")