$re = '/^\/.*(?<!foo\/bar\/(aaa|bbb|ccc|ddd))$/m';
$str = '/toto/titi
/foo/toto
/foo/bar/aaa
/foo/bar/bbb
/bar/yeepa
/foo/bar/ccc
/foo/bar/ddd
/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);