using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/.*(?<!foo\/bar\/(aaa|bbb|ccc|ddd))$";
string input = @"/toto/titi
/foo/toto
/foo/bar/aaa
/foo/bar/bbb
/bar/yeepa
/foo/bar/ccc
/foo/bar/ddd
/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}