const regex = /(?<=OH_|ma)(\w)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=OH_|ma)(\\w)+', 'g')
const str = `OH_OrderItemStatusChanged
Style1PS1A1OH_OrderItemStatusSpacerOH_OrderItemStatusID_2
(OH_OrderItemSentTo ) (OH_SalesRep )OH_OH_OH_SalesRepSalesRepSalesRep
OH_OH_maSalesRepSalesRepSalesRep`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}