$re = '/(?<=OH_|ma)(\w)+/';
$str = 'OH_OrderItemStatusChanged
Style1PS1A1OH_OrderItemStatusSpacerOH_OrderItemStatusID_2
(OH_OrderItemSentTo ) (OH_SalesRep )OH_OH_OH_SalesRepSalesRepSalesRep
OH_OH_maSalesRepSalesRepSalesRep';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);