re = /(?<=OH_|ma)(\w)+/
str = 'OH_OrderItemStatusChanged
Style1PS1A1OH_OrderItemStatusSpacerOH_OrderItemStatusID_2
(OH_OrderItemSentTo ) (OH_SalesRep )OH_OH_OH_SalesRepSalesRepSalesRep
OH_OH_maSalesRepSalesRepSalesRep'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end