#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\#?\w+"
Local $sString = "class CfgPatches {" & @CRLF & _
" class q {" & @CRLF & _
" t = QUOTE(B(C); call f);" & @CRLF & _
" o = #s;" & @CRLF & _
" };" & @CRLF & _
"};" & @CRLF & _
"QUOTE("test")" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")