package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\#?\w+`)
var str = `class CfgPatches {
class q {
t = QUOTE(B(C); call f);
o = #s;
};
};
QUOTE("test")
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}