$re = '/\#?\w+/';
$str = 'class CfgPatches {
class q {
t = QUOTE(B(C); call f);
o = #s;
};
};
QUOTE("test")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);