#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+-?[a-zA-Z]+\s[a-zA-Z]+\s[a-zA-Z]+-?[a-zA-Z]+"
Local $sString = "Keith a Johnson" & @CRLF & _
"Kei-th f Jo-hnson" & @CRLF & _
"Kei Th John-son" & @CRLF & _
"Kei-th Jo Hnson" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")