$re = '/[a-zA-Z]+-?[a-zA-Z]+\s[a-zA-Z]+\s[a-zA-Z]+-?[a-zA-Z]+/';
$str = 'Keith a Johnson
Kei-th f Jo-hnson
Kei Th John-son
Kei-th Jo Hnson
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);