package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z]+-?[a-zA-Z]+\s[a-zA-Z]+\s[a-zA-Z]+-?[a-zA-Z]+`)
var str = `Keith a Johnson
Kei-th f Jo-hnson
Kei Th John-son
Kei-th Jo Hnson
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}