#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(triple|double)\s+(\w+\s+)?box"
Local $sString = "Moët & Chandon Brut Impérial NV Triple Wood Box" & @CRLF & _
"Moët & Chandon Brut Impérial NV & Rosé NV Double Wood Box" & @CRLF & _
"Moët & Chandon Brut Impérial NV Double Wood Box"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")