$re = '/(triple|double)\s+(\w+\s+)?box/mi';
$str = 'Moët & Chandon Brut Impérial NV Triple Wood Box
Moët & Chandon Brut Impérial NV & Rosé NV Double Wood Box
Moët & Chandon Brut Impérial NV Double Wood Box';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);