re = /(triple|double)\s+(\w+\s+)?box/mi
str = 'Moët & Chandon Brut Impérial NV Triple Wood Box
Moët & Chandon Brut Impérial NV & Rosé NV Double Wood Box
Moët & Chandon Brut Impérial NV Double Wood Box'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end