use strict;
my $str = 'Medically reviewed by Andrea Hodgson — Written by Susan York Morris — Updated on September 2, 2018
Introduction
Тест тест тест тест тест тест тест тест тест.
Kdenfjr - fkefkwfwf kljmlk lklkjol klmlmkl klkoik kjio.
Erectile dysfunction (ED) is a problem with getting and maintaining an erection that’s firm enough to have sexual intercourse. All men have trouble getting an erection from time to time, and the likelihood of this problem increases with age. If it happens to you often, though, you may have ED.
Viagra is a prescription drug that can help men with erectile dysfunction. For many people, romance means candlelight, soft music, and a glass of wine. The little blue pill, Viagra, can be part of this picture, but only if you drink small or moderate amounts of alcohol.';
my $regex = qr/(\b[A-ZА-Я](?:\w+[,;:’()-]? ){3,}\w{1,}[.!?])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}