import re
regex = re.compile(r"(\b[A-ZА-Я](?:\w+[,;:’()-]? ){3,}\w{1,}[.!?])", flags=re.MULTILINE)
test_str = ("Medically reviewed by Andrea Hodgson — Written by Susan York Morris — Updated on September 2, 2018\n"
"Introduction\n"
"Тест тест тест тест тест тест тест тест тест.\n"
"Kdenfjr - fkefkwfwf kljmlk lklkjol klmlmkl klkoik kjio.\n"
"Erectile dysfunction (ED) is a problem with getting and maintaining an erection that’s firm enough to have sexual intercourse. All men have trouble getting an erection from time to time, and the likelihood of this problem increases with age. If it happens to you often, though, you may have ED.\n"
"Viagra is a prescription drug that can help men with erectile dysfunction. For many people, romance means candlelight, soft music, and a glass of wine. The little blue pill, Viagra, can be part of this picture, but only if you drink small or moderate amounts of alcohol.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")