// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b[A-ZА-Я](?:\w+[,;:’()-]? ){3,}\w{1,}[.!?])").unwrap();
let string = "Medically reviewed by Andrea Hodgson — Written by Susan York Morris — Updated on September 2, 2018
Introduction
Тест тест тест тест тест тест тест тест тест.
Kdenfjr - fkefkwfwf kljmlk lklkjol klmlmkl klkoik kjio.
Erectile dysfunction (ED) is a problem with getting and maintaining an erection that’s firm enough to have sexual intercourse. All men have trouble getting an erection from time to time, and the likelihood of this problem increases with age. If it happens to you often, though, you may have ED.
Viagra is a prescription drug that can help men with erectile dysfunction. For many people, romance means candlelight, soft music, and a glass of wine. The little blue pill, Viagra, can be part of this picture, but only if you drink small or moderate amounts of alcohol.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}