package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{7}|\d{6},\d|\d{5},\d{2})`)
var str = `5555555
555555,5
55555,55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}