const regex = /(\d{7}|\d{6},\d|\d{5},\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{7}|\\d{6},\\d|\\d{5},\\d{2})', 'g')
const str = `5555555
555555,5
55555,55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}