$re = '/(\d{7}|\d{6},\d|\d{5},\d{2})/';
$str = '5555555
555555,5
55555,55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);