#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+)),? (?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-/+,] ?)[\d\p{L}]+)*?)$"
Local $sString = "Test-Straße 1" & @CRLF & _
"Chaussée de Tirlemont 373" & @CRLF & _
"Mühlenstraße 23" & @CRLF & _
"Straße des 17. Juni 135" & @CRLF & _
"4th Street 12ab" & @CRLF & _
"3rd Avenue 1435" & @CRLF & _
"Hamburger Str. 11-19" & @CRLF & _
"K4 12" & @CRLF & _
"Test-Str. 12ab" & @CRLF & _
"Test-Str. 12a-d" & @CRLF & _
"Test Str. 51 16" & @CRLF & _
"Test-Str. 17/18" & @CRLF & _
"Test Str. QA/3/31" & @CRLF & _
"Test Str. 51 / XX / 31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")