import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<street>(?!\\d+ )[\\p{L}\\d'\\u2018-\\u2019]+\\.?(?:[ -][\\p{L}\\d'\\u2018-\\u2019]+\\.?)*(?<! \\d+)),? (?<houseNumber>[1-9\\p{L}][\\d\\p{L}]*(?:(?: | ?[\\-/+,] ?)[\\d\\p{L}]+)*?)$";
final String string = "Test-Straße 1\n"
+ "Chaussée de Tirlemont 373\n"
+ "Mühlenstraße 23\n"
+ "Straße des 17. Juni 135\n"
+ "4th Street 12ab\n"
+ "3rd Avenue 1435\n"
+ "Hamburger Str. 11-19\n"
+ "K4 12\n"
+ "Test-Str. 12ab\n"
+ "Test-Str. 12a-d\n"
+ "Test Str. 51 16\n"
+ "Test-Str. 17/18\n"
+ "Test Str. QA/3/31\n"
+ "Test Str. 51 / XX / 31";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}