re = /^(?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+)),? (?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-\/+,] ?)[\d\p{L}]+)*?)$/m
str = 'Test-Straße 1
Chaussée de Tirlemont 373
Mühlenstraße 23
Straße des 17. Juni 135
4th Street 12ab
3rd Avenue 1435
Hamburger Str. 11-19
K4 12
Test-Str. 12ab
Test-Str. 12a-d
Test Str. 51 16
Test-Str. 17/18
Test Str. QA/3/31
Test Str. 51 / XX / 31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end