$re = '/a.*p.*p.*h.*t.*.*c.*o.*n.*t.*s.*e.*a.*/mi';
$str = 'app/Http/Controllers/SearchController.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);